aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index f0a69b4..55efcc5 100644
--- a/shell.nix
+++ b/shell.nix
@@ -5,13 +5,13 @@
5let 5let
6 thermoprintPackages = builtins.attrValues (import ./default.nix {}); 6 thermoprintPackages = builtins.attrValues (import ./default.nix {});
7 ghc = haskellPackages.ghcWithPackages 7 ghc = haskellPackages.ghcWithPackages
8 (ps: thermoprintPackages ++ utilities ps ++ testDeps ps); 8 (ps: utilities ps ++ testDeps ps);
9 utilities = (ps: with ps; [ hlint cabal2nix ]); 9 utilities = (ps: with ps; [ hlint cabal2nix ]);
10 testDeps = (ps: with ps; [ temporary hspec ]); 10 testDeps = (ps: with ps; [ temporary hspec ]);
11in 11in
12pkgs.stdenv.mkDerivation rec { 12pkgs.stdenv.mkDerivation rec {
13 name = "thermoprint-env"; 13 name = "thermoprint-env";
14 buildInputs = [ ghc ]; 14 buildInputs = (with pkgs; [ gup ]) ++ [ ghc ];
15 shellHook = '' 15 shellHook = ''
16 eval $(egrep ^export ${ghc}/bin/ghc) 16 eval $(egrep ^export ${ghc}/bin/ghc)
17 export PROMPT_INFO="${name}" 17 export PROMPT_INFO="${name}"