aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <pngwjpgh@users.noreply.github.com>2017-01-23 16:08:09 +0100
committerGregor Kleen <pngwjpgh@users.noreply.github.com>2017-01-23 16:08:09 +0100
commit59a7e3d173c23096fe3122505b1b759f26e3292a (patch)
treef974b10be38bea77b674a6bb3ef9da0e4a06f795 /shell.nix
parent023678dc00bcc5ebb93a33cec762f48cb9cf80ff (diff)
downloadthermoprint-59a7e3d173c23096fe3122505b1b759f26e3292a.tar
thermoprint-59a7e3d173c23096fe3122505b1b759f26e3292a.tar.gz
thermoprint-59a7e3d173c23096fe3122505b1b759f26e3292a.tar.bz2
thermoprint-59a7e3d173c23096fe3122505b1b759f26e3292a.tar.xz
thermoprint-59a7e3d173c23096fe3122505b1b759f26e3292a.zip
Fix build
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index f0a69b4..55efcc5 100644
--- a/shell.nix
+++ b/shell.nix
@@ -5,13 +5,13 @@
5let 5let
6 thermoprintPackages = builtins.attrValues (import ./default.nix {}); 6 thermoprintPackages = builtins.attrValues (import ./default.nix {});
7 ghc = haskellPackages.ghcWithPackages 7 ghc = haskellPackages.ghcWithPackages
8 (ps: thermoprintPackages ++ utilities ps ++ testDeps ps); 8 (ps: utilities ps ++ testDeps ps);
9 utilities = (ps: with ps; [ hlint cabal2nix ]); 9 utilities = (ps: with ps; [ hlint cabal2nix ]);
10 testDeps = (ps: with ps; [ temporary hspec ]); 10 testDeps = (ps: with ps; [ temporary hspec ]);
11in 11in
12pkgs.stdenv.mkDerivation rec { 12pkgs.stdenv.mkDerivation rec {
13 name = "thermoprint-env"; 13 name = "thermoprint-env";
14 buildInputs = [ ghc ]; 14 buildInputs = (with pkgs; [ gup ]) ++ [ ghc ];
15 shellHook = '' 15 shellHook = ''
16 eval $(egrep ^export ${ghc}/bin/ghc) 16 eval $(egrep ^export ${ghc}/bin/ghc)
17 export PROMPT_INFO="${name}" 17 export PROMPT_INFO="${name}"