aboutsummaryrefslogtreecommitdiff
path: root/servant/servant.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2015-09-14 22:07:20 +0000
committerGregor Kleen <gkleen@yggdrasil.li>2015-09-14 22:07:20 +0000
commit3402bbc71d4492caff4098b9606a58ab18ab67c2 (patch)
tree4fe98ac24455da8e07188e4aa803abe05b79af14 /servant/servant.nix
downloadthermoprint-3402bbc71d4492caff4098b9606a58ab18ab67c2.tar
thermoprint-3402bbc71d4492caff4098b9606a58ab18ab67c2.tar.gz
thermoprint-3402bbc71d4492caff4098b9606a58ab18ab67c2.tar.bz2
thermoprint-3402bbc71d4492caff4098b9606a58ab18ab67c2.tar.xz
thermoprint-3402bbc71d4492caff4098b9606a58ab18ab67c2.zip
First shot at basic structure
The planned webapp is missing for now. `nix-build -A servant` fails because thermoprint does not seem to be registered with ghc (see `echo 'import Thermoprint' | nix-shell -p 'ghci'`)
Diffstat (limited to 'servant/servant.nix')
-rw-r--r--servant/servant.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/servant/servant.nix b/servant/servant.nix
new file mode 100644
index 0000000..6c90a4f
--- /dev/null
+++ b/servant/servant.nix
@@ -0,0 +1,19 @@
1{ mkDerivation
2, stdenv
3, base
4, thermoprint
5}:
6
7mkDerivation {
8 pname = "thermoprint-servant";
9 version = "0.0.0";
10 src = ./.;
11 isLibrary = false;
12 isExecutable = true;
13 executableHaskellDepends = [
14 base thermoprint
15 ];
16 homepage = "git://git.yggdrasil.li/thermoprint";
17 description = "Server for interfacing to cheap thermoprinters";
18 license = stdenv.lib.licenses.publicDomain;
19}