summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/shell.nix b/shell.nix
index f5c0d625..5f883cd1 100644
--- a/shell.nix
+++ b/shell.nix
@@ -3,11 +3,9 @@ let
3 pkgs = self.legacyPackages.${system}; 3 pkgs = self.legacyPackages.${system};
4 utils = import ./utils { inherit (nixpkgs) lib; }; 4 utils = import ./utils { inherit (nixpkgs) lib; };
5 inherit (utils) nixImport; 5 inherit (utils) nixImport;
6
7 tools = nixImport rec { dir = ./tools; _import = _path: name: import "${toString dir}/${name}" inputs; };
8in pkgs.mkShell { 6in pkgs.mkShell {
9 name = "nixos"; 7 name = "nixos";
10 nativeBuildInputs = builtins.attrValues tools ++ (with pkgs; [ 8 nativeBuildInputs = builtins.attrValues self.packages.${system} ++ (with pkgs; [
11 sops 9 sops
12 wireguard-tools 10 wireguard-tools
13 gup 11 gup