summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2023-01-18 08:33:46 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2023-01-18 08:33:46 +0100
commit6b0fd8d0197eccd18a6e079e5d9c58d40002ba44 (patch)
treef30b82828b2ca7bd79fd517ac70391440741b141 /shell.nix
parentbd30654df189b3b4693ea1bb81b23d1338846ad3 (diff)
downloadnixos-6b0fd8d0197eccd18a6e079e5d9c58d40002ba44.tar
nixos-6b0fd8d0197eccd18a6e079e5d9c58d40002ba44.tar.gz
nixos-6b0fd8d0197eccd18a6e079e5d9c58d40002ba44.tar.bz2
nixos-6b0fd8d0197eccd18a6e079e5d9c58d40002ba44.tar.xz
nixos-6b0fd8d0197eccd18a6e079e5d9c58d40002ba44.zip
...
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/shell.nix b/shell.nix
index f5c0d625..5f883cd1 100644
--- a/shell.nix
+++ b/shell.nix
@@ -3,11 +3,9 @@ let
3 pkgs = self.legacyPackages.${system}; 3 pkgs = self.legacyPackages.${system};
4 utils = import ./utils { inherit (nixpkgs) lib; }; 4 utils = import ./utils { inherit (nixpkgs) lib; };
5 inherit (utils) nixImport; 5 inherit (utils) nixImport;
6
7 tools = nixImport rec { dir = ./tools; _import = _path: name: import "${toString dir}/${name}" inputs; };
8in pkgs.mkShell { 6in pkgs.mkShell {
9 name = "nixos"; 7 name = "nixos";
10 nativeBuildInputs = builtins.attrValues tools ++ (with pkgs; [ 8 nativeBuildInputs = builtins.attrValues self.packages.${system} ++ (with pkgs; [
11 sops 9 sops
12 wireguard-tools 10 wireguard-tools
13 gup 11 gup