summaryrefslogtreecommitdiff
path: root/nix/notmuch-tcp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/notmuch-tcp.nix')
-rw-r--r--nix/notmuch-tcp.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/nix/notmuch-tcp.nix b/nix/notmuch-tcp.nix
new file mode 100644
index 0000000..438a086
--- /dev/null
+++ b/nix/notmuch-tcp.nix
@@ -0,0 +1,22 @@
1{ stdenv
2, zsh, socat, nettools
3}:
4
5stdenv.mkDerivation rec {
6 pname = "notmuch-tcp";
7 version = "0.1";
8 src = ../notmuch-tcp;
9
10 phases = [ "buildPhase" "installPhase" ];
11
12 inherit zsh socat nettools;
13
14 buildPhase = ''
15 substituteAll $src notmuch-tcp
16 '';
17
18 installPhase = ''
19 install -m 0755 -D -t $out/bin \
20 notmuch-tcp
21 '';
22}