summaryrefslogtreecommitdiff
path: root/nix/notmuch-tcp.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2019-11-24 20:06:28 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2019-11-24 20:06:28 +0100
commitf28f4fc1bef6ebabb9c340c3fdfb92eee1423c5c (patch)
tree866bf3a0b3f0d67d5b3867a75f479018b95e3d0d /nix/notmuch-tcp.nix
parenta7f511e7c9e8099db097d58c4fa6775766850c56 (diff)
downloadutils-f28f4fc1bef6ebabb9c340c3fdfb92eee1423c5c.tar
utils-f28f4fc1bef6ebabb9c340c3fdfb92eee1423c5c.tar.gz
utils-f28f4fc1bef6ebabb9c340c3fdfb92eee1423c5c.tar.bz2
utils-f28f4fc1bef6ebabb9c340c3fdfb92eee1423c5c.tar.xz
utils-f28f4fc1bef6ebabb9c340c3fdfb92eee1423c5c.zip
notmuch-tcp
Diffstat (limited to 'nix/notmuch-tcp.nix')
-rw-r--r--nix/notmuch-tcp.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/nix/notmuch-tcp.nix b/nix/notmuch-tcp.nix
new file mode 100644
index 0000000..438a086
--- /dev/null
+++ b/nix/notmuch-tcp.nix
@@ -0,0 +1,22 @@
1{ stdenv
2, zsh, socat, nettools
3}:
4
5stdenv.mkDerivation rec {
6 pname = "notmuch-tcp";
7 version = "0.1";
8 src = ../notmuch-tcp;
9
10 phases = [ "buildPhase" "installPhase" ];
11
12 inherit zsh socat nettools;
13
14 buildPhase = ''
15 substituteAll $src notmuch-tcp
16 '';
17
18 installPhase = ''
19 install -m 0755 -D -t $out/bin \
20 notmuch-tcp
21 '';
22}