summaryrefslogtreecommitdiff
path: root/nix/notmuch-links.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/notmuch-links.nix')
-rw-r--r--nix/notmuch-links.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/nix/notmuch-links.nix b/nix/notmuch-links.nix
new file mode 100644
index 0000000..67ebe3b
--- /dev/null
+++ b/nix/notmuch-links.nix
@@ -0,0 +1,24 @@
1{ stdenv
2, notmuch-tcp
3, zsh, coreutils, gawk, gnused
4}:
5
6stdenv.mkDerivation rec {
7 pname = "notmuch-links";
8 version = "0.1";
9 src = ../notmuch-links;
10
11 phases = [ "buildPhase" "installPhase" ];
12
13 inherit zsh coreutils gawk gnused;
14 notmuchtcp = notmuch-tcp;
15
16 buildPhase = ''
17 substituteAll $src notmuch-links
18 '';
19
20 installPhase = ''
21 install -m 0755 -D -t $out/bin \
22 notmuch-links
23 '';
24}