summaryrefslogtreecommitdiff
path: root/nix/persistent-nix-shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2020-02-29 12:18:11 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2020-02-29 12:18:11 +0100
commitb02413acfbbb1e541fcb9218d6930dbf283c7211 (patch)
treee6d1827123cefea4c25e83874fe4f2f6f2381a5e /nix/persistent-nix-shell.nix
parentaa58927f86322757cc85fa469564e8b05ddcdcda (diff)
parentc39a6086a83c2547534d943e3611c4ce0524fafa (diff)
downloadutils-b02413acfbbb1e541fcb9218d6930dbf283c7211.tar
utils-b02413acfbbb1e541fcb9218d6930dbf283c7211.tar.gz
utils-b02413acfbbb1e541fcb9218d6930dbf283c7211.tar.bz2
utils-b02413acfbbb1e541fcb9218d6930dbf283c7211.tar.xz
utils-b02413acfbbb1e541fcb9218d6930dbf283c7211.zip
Merge branch 'master' of git.yggdrasil.li:utils
Diffstat (limited to 'nix/persistent-nix-shell.nix')
-rw-r--r--nix/persistent-nix-shell.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/nix/persistent-nix-shell.nix b/nix/persistent-nix-shell.nix
new file mode 100644
index 0000000..7b371c6
--- /dev/null
+++ b/nix/persistent-nix-shell.nix
@@ -0,0 +1,22 @@
1{ stdenv
2, zsh
3}:
4
5stdenv.mkDerivation rec {
6 pname = "persistent-nix-shell";
7 version = "0.1";
8 src = ../persistent-nix-shell;
9
10 phases = [ "buildPhase" "installPhase" ];
11
12 inherit zsh;
13
14 buildPhase = ''
15 substituteAll $src persistent-nix-shell
16 '';
17
18 installPhase = ''
19 install -m 0755 -D -t $out/bin \
20 persistent-nix-shell
21 '';
22}