summaryrefslogtreecommitdiff
path: root/nix/persistent-nix-shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2019-11-24 20:39:26 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2019-11-24 20:39:26 +0100
commit61e8781e600a916e51fd663c4d8cd5d93bb894cb (patch)
tree15a8e9abf15f5ebd8e2e692a9fc43a7124fae93e /nix/persistent-nix-shell.nix
parentf55aa62c7dd25d44b37985ef5f109eb8212f5ae7 (diff)
downloadutils-61e8781e600a916e51fd663c4d8cd5d93bb894cb.tar
utils-61e8781e600a916e51fd663c4d8cd5d93bb894cb.tar.gz
utils-61e8781e600a916e51fd663c4d8cd5d93bb894cb.tar.bz2
utils-61e8781e600a916e51fd663c4d8cd5d93bb894cb.tar.xz
utils-61e8781e600a916e51fd663c4d8cd5d93bb894cb.zip
persistent-nix-shell
Diffstat (limited to 'nix/persistent-nix-shell.nix')
-rw-r--r--nix/persistent-nix-shell.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/nix/persistent-nix-shell.nix b/nix/persistent-nix-shell.nix
new file mode 100644
index 0000000..7b371c6
--- /dev/null
+++ b/nix/persistent-nix-shell.nix
@@ -0,0 +1,22 @@
1{ stdenv
2, zsh
3}:
4
5stdenv.mkDerivation rec {
6 pname = "persistent-nix-shell";
7 version = "0.1";
8 src = ../persistent-nix-shell;
9
10 phases = [ "buildPhase" "installPhase" ];
11
12 inherit zsh;
13
14 buildPhase = ''
15 substituteAll $src persistent-nix-shell
16 '';
17
18 installPhase = ''
19 install -m 0755 -D -t $out/bin \
20 persistent-nix-shell
21 '';
22}