summaryrefslogtreecommitdiff
path: root/nix/notmuch-tcp.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2020-03-07 16:27:55 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2020-03-07 16:27:55 +0100
commitc9f21862006f50937f22f51155ee81ff47399730 (patch)
tree143817679d60a8b50de7c7730ca08170c0dc8927 /nix/notmuch-tcp.nix
parentc39a6086a83c2547534d943e3611c4ce0524fafa (diff)
downloadutils-c9f21862006f50937f22f51155ee81ff47399730.tar
utils-c9f21862006f50937f22f51155ee81ff47399730.tar.gz
utils-c9f21862006f50937f22f51155ee81ff47399730.tar.bz2
utils-c9f21862006f50937f22f51155ee81ff47399730.tar.xz
utils-c9f21862006f50937f22f51155ee81ff47399730.zip
bump
Diffstat (limited to 'nix/notmuch-tcp.nix')
-rw-r--r--nix/notmuch-tcp.nix22
1 files changed, 15 insertions, 7 deletions
diff --git a/nix/notmuch-tcp.nix b/nix/notmuch-tcp.nix
index 59d2e39..1a1947b 100644
--- a/nix/notmuch-tcp.nix
+++ b/nix/notmuch-tcp.nix
@@ -1,22 +1,30 @@
1{ stdenv 1{ stdenv
2, zsh, socat, nettools, coreutils 2, python38
3}: 3}:
4 4
5stdenv.mkDerivation rec { 5stdenv.mkDerivation rec {
6 pname = "notmuch-tcp"; 6 pname = "notmuch-tcp";
7 version = "0.1"; 7 version = "1.0";
8 src = ../notmuch-tcp; 8 src = [../notmuch-tcp-client ../notmuch-tcp-server];
9 9
10 phases = [ "buildPhase" "installPhase" ]; 10 phases = [ "unpackPhase" "buildPhase" "installPhase" ];
11 11
12 inherit zsh socat nettools coreutils; 12 python = python38;
13
14 unpackPhase = ''
15 for srcFile in $src; do
16 cp $srcFile $(stripHash $srcFile)
17 done
18 '';
13 19
14 buildPhase = '' 20 buildPhase = ''
15 substituteAll $src notmuch-tcp 21 substituteAllInPlace notmuch-tcp-client
22 substituteAllInPlace notmuch-tcp-server
16 ''; 23 '';
17 24
18 installPhase = '' 25 installPhase = ''
19 install -m 0755 -D -t $out/bin \ 26 install -m 0755 -D -t $out/bin \
20 notmuch-tcp 27 notmuch-tcp-client notmuch-tcp-server
28 ln -s notmuch-tcp-client $out/bin/notmuch-tcp
21 ''; 29 '';
22} 30}