summaryrefslogtreecommitdiff
path: root/trivmix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'trivmix.nix')
-rw-r--r--trivmix.nix14
1 files changed, 8 insertions, 6 deletions
diff --git a/trivmix.nix b/trivmix.nix
index 690e184..6fc16d9 100644
--- a/trivmix.nix
+++ b/trivmix.nix
@@ -1,22 +1,24 @@
1{ mkDerivation, base, case-insensitive, concurrent-output 1{ mkDerivation, base, case-insensitive, concurrent-output
2, data-default, directory, explicit-exception, filelock, filepath 2, data-default, directory, explicit-exception, filelock, filepath
3, heredoc, hinotify, hpack, jack, optparse-applicative, process 3, heredoc, hinotify, hpack, ieee754, jack, optparse-applicative
4, refined, scientific, stdenv, systemd, th-lift, transformers, unix 4, process, refined, scientific, stdenv, systemd, th-lift
5, transformers, unix
5}: 6}:
6mkDerivation { 7mkDerivation {
7 pname = "trivmix"; 8 pname = "trivmix";
8 version = "4.0.3"; 9 version = "4.1.0";
9 src = ./.; 10 src = ./.;
10 isLibrary = true; 11 isLibrary = true;
11 isExecutable = true; 12 isExecutable = true;
12 libraryHaskellDepends = [ 13 libraryHaskellDepends = [
13 base case-insensitive data-default refined scientific th-lift 14 base case-insensitive data-default ieee754 refined scientific
15 th-lift
14 ]; 16 ];
15 libraryToolDepends = [ hpack ]; 17 libraryToolDepends = [ hpack ];
16 executableHaskellDepends = [ 18 executableHaskellDepends = [
17 base concurrent-output directory explicit-exception filelock 19 base concurrent-output directory explicit-exception filelock
18 filepath heredoc hinotify jack optparse-applicative process refined 20 filepath heredoc hinotify ieee754 jack optparse-applicative process
19 scientific systemd transformers unix 21 refined scientific systemd transformers unix
20 ]; 22 ];
21 preConfigure = "hpack"; 23 preConfigure = "hpack";
22 license = stdenv.lib.licenses.publicDomain; 24 license = stdenv.lib.licenses.publicDomain;