aboutsummaryrefslogtreecommitdiff
path: root/webgui/thermoprint-webgui.nix
diff options
context:
space:
mode:
Diffstat (limited to 'webgui/thermoprint-webgui.nix')
-rw-r--r--webgui/thermoprint-webgui.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/webgui/thermoprint-webgui.nix b/webgui/thermoprint-webgui.nix
new file mode 100644
index 0000000..0450eae
--- /dev/null
+++ b/webgui/thermoprint-webgui.nix
@@ -0,0 +1,17 @@
1{ mkDerivation, base, bytestring, optparse-applicative, stdenv
2, thermoprint-bbcode, thermoprint-client, threepenny-gui
3}:
4mkDerivation {
5 pname = "thermoprint-webgui";
6 version = "0.0.0";
7 src = ./.;
8 isLibrary = false;
9 isExecutable = true;
10 executableHaskellDepends = [
11 base bytestring optparse-applicative thermoprint-bbcode
12 thermoprint-client threepenny-gui
13 ];
14 homepage = "http://dirty-haskell.org/tags/thermoprint.html";
15 description = "Threepenny interface for thermoprint-spec compliant servers";
16 license = stdenv.lib.licenses.publicDomain;
17}