aboutsummaryrefslogtreecommitdiff
path: root/tprint/tprint.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tprint/tprint.nix')
-rw-r--r--tprint/tprint.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/tprint/tprint.nix b/tprint/tprint.nix
new file mode 100644
index 0000000..cce38c4
--- /dev/null
+++ b/tprint/tprint.nix
@@ -0,0 +1,20 @@
1{ mkDerivation
2, stdenv
3, base
4, thermoprint-servant, thermoprint, bbcode
5, optparse-applicative, servant-client
6}:
7mkDerivation {
8 pname = "tprint";
9 version = "0.0.0";
10 src = ./.;
11 isLibrary = false;
12 isExecutable = true;
13 executableHaskellDepends = [ base
14 thermoprint thermoprint-servant bbcode
15 optparse-applicative servant-client
16 ];
17 homepage = "git://git.yggdrasil.li/thermoprint";
18 description = "A cli-tool for interfacing with thermoprint-servant";
19 license = stdenv.lib.licenses.publicDomain;
20}