aboutsummaryrefslogtreecommitdiff
path: root/tp-bbcode/thermoprint-bbcode.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tp-bbcode/thermoprint-bbcode.nix')
-rw-r--r--tp-bbcode/thermoprint-bbcode.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/tp-bbcode/thermoprint-bbcode.nix b/tp-bbcode/thermoprint-bbcode.nix
new file mode 100644
index 0000000..9a48152
--- /dev/null
+++ b/tp-bbcode/thermoprint-bbcode.nix
@@ -0,0 +1,19 @@
1{ mkDerivation, aeson, base, bbcode, case-insensitive, containers
2, hspec, QuickCheck, quickcheck-instances, stdenv, text
3, thermoprint-spec
4}:
5mkDerivation {
6 pname = "thermoprint-bbcode";
7 version = "0.0.0";
8 src = ./.;
9 libraryHaskellDepends = [
10 base bbcode case-insensitive containers text thermoprint-spec
11 ];
12 testHaskellDepends = [
13 aeson base containers hspec QuickCheck quickcheck-instances text
14 thermoprint-spec
15 ];
16 homepage = "http://dirty-haskell.org/tags/thermoprint.html";
17 description = "Parse bbcode for use in thermoprint";
18 license = stdenv.lib.licenses.publicDomain;
19}