aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/shell.nix b/shell.nix
index 9c4dbfe..c48100d 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,11 +1,12 @@
1{ pkgs ? (import <nixpkgs> {}) 1{ pkgs ? (import <nixpkgs> {})
2, compiler ? "ghc7102" 2, compilerName ? "ghc7102"
3}: 3}:
4 4
5let 5let
6 ghc = pkgs.haskell.packages.${compiler}.ghcWithHoogle (ps: with ps; [ 6 packages = ps: with ps; [
7 cabal-install hlint cabal2nix 7 cabal-install hlint cabal2nix
8 ] ++ (builtins.attrValues (import ./default.nix {}))); 8 ] ++ (builtins.attrValues (import ./default.nix {}));
9 ghc = pkgs.haskell.packages.${compilerName}.ghcWithHoogle packages;
9in 10in
10pkgs.stdenv.mkDerivation rec { 11pkgs.stdenv.mkDerivation rec {
11 name = "thermoprint-env"; 12 name = "thermoprint-env";