aboutsummaryrefslogtreecommitdiff
path: root/servant/servant.nix
diff options
context:
space:
mode:
Diffstat (limited to 'servant/servant.nix')
-rw-r--r--servant/servant.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/servant/servant.nix b/servant/servant.nix
deleted file mode 100644
index 5ea8d59..0000000
--- a/servant/servant.nix
+++ /dev/null
@@ -1,22 +0,0 @@
1{ mkDerivation
2, stdenv
3, base
4, thermoprint
5, aeson, wai, servant-server, warp, optparse-applicative, persistent
6, persistent-template, persistent-sqlite, monad-logger
7}:
8
9mkDerivation {
10 pname = "thermoprint-servant";
11 version = "0.0.0";
12 src = ./.;
13 isLibrary = true;
14 isExecutable = true;
15 executableHaskellDepends = [
16 base thermoprint aeson wai servant-server warp optparse-applicative
17 persistent persistent-template persistent-sqlite monad-logger
18 ];
19 homepage = "git://git.yggdrasil.li/thermoprint";
20 description = "Server for interfacing to cheap thermoprinters";
21 license = stdenv.lib.licenses.publicDomain;
22}