aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2015-12-25 17:56:13 +0000
committerGregor Kleen <gkleen@yggdrasil.li>2015-12-25 17:56:13 +0000
commit9db2c42f4880362cf098358de830415c14f6878c (patch)
tree2b0b9257f01eec926152746fc2e7646764063c3a /shell.nix
parent08eee2f0de77ffa631e84ccf734e8e95817b7c81 (diff)
downloadthermoprint-9db2c42f4880362cf098358de830415c14f6878c.tar
thermoprint-9db2c42f4880362cf098358de830415c14f6878c.tar.gz
thermoprint-9db2c42f4880362cf098358de830415c14f6878c.tar.bz2
thermoprint-9db2c42f4880362cf098358de830415c14f6878c.tar.xz
thermoprint-9db2c42f4880362cf098358de830415c14f6878c.zip
Cleaned tree for rewrite
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix14
1 files changed, 0 insertions, 14 deletions
diff --git a/shell.nix b/shell.nix
deleted file mode 100644
index df3ed18..0000000
--- a/shell.nix
+++ /dev/null
@@ -1,14 +0,0 @@
1{ pkgs ? (import <nixpkgs> {})
2, compiler ? "ghc7102"
3}:
4
5let
6 ghc = pkgs.haskell.packages.${compiler}.ghcWithPackages (ps: with ps; [
7 cabal-install hlint cabal2nix
8 ] ++ (builtins.attrValues (import ./default.nix {})));
9in
10pkgs.stdenv.mkDerivation {
11 name = "thermoprinter-env";
12 buildInputs = [ ghc ];
13 shellHook = "eval $(egrep ^export ${ghc}/bin/ghc)";
14}