aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2016-02-19 14:21:47 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2016-02-19 14:21:47 +0100
commit9585d245212572b2c599b3c10cfba545e42f46d1 (patch)
tree5b503edccfccf2b9f694460af69e72f06a30e93b /shell.nix
parenta6fafcc31f81b12bcffebec77cbba80aa422671d (diff)
downloadthermoprint-9585d245212572b2c599b3c10cfba545e42f46d1.tar
thermoprint-9585d245212572b2c599b3c10cfba545e42f46d1.tar.gz
thermoprint-9585d245212572b2c599b3c10cfba545e42f46d1.tar.bz2
thermoprint-9585d245212572b2c599b3c10cfba545e42f46d1.tar.xz
thermoprint-9585d245212572b2c599b3c10cfba545e42f46d1.zip
Unified ghc version used across build
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index d6f2e43..f0a69b4 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,10 +1,10 @@
1{ pkgs ? (import <nixpkgs> {}) 1{ pkgs ? (import <nixpkgs> {})
2, compilerName ? "ghc7103" 2, haskellPackages ? (import ./default.nix {}).haskellPackages
3}: 3}:
4 4
5let 5let
6 thermoprintPackages = builtins.attrValues (import ./default.nix {}); 6 thermoprintPackages = builtins.attrValues (import ./default.nix {});
7 ghc = pkgs.haskell.packages.${compilerName}.ghcWithPackages 7 ghc = haskellPackages.ghcWithPackages
8 (ps: thermoprintPackages ++ utilities ps ++ testDeps ps); 8 (ps: thermoprintPackages ++ utilities ps ++ testDeps ps);
9 utilities = (ps: with ps; [ hlint cabal2nix ]); 9 utilities = (ps: with ps; [ hlint cabal2nix ]);
10 testDeps = (ps: with ps; [ temporary hspec ]); 10 testDeps = (ps: with ps; [ temporary hspec ]);