aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2015-12-25 18:06:14 +0000
committerGregor Kleen <gkleen@yggdrasil.li>2015-12-25 18:06:14 +0000
commit7a5a7c49c4e6a3050e21e7ddb8a7ea0870db1c0f (patch)
tree2b93dfed620fa6687effa0fa238214d0a2536441 /shell.nix
parent35f32ec0d8d9655c083ea585d9e408315e708619 (diff)
downloadthermoprint-7a5a7c49c4e6a3050e21e7ddb8a7ea0870db1c0f.tar
thermoprint-7a5a7c49c4e6a3050e21e7ddb8a7ea0870db1c0f.tar.gz
thermoprint-7a5a7c49c4e6a3050e21e7ddb8a7ea0870db1c0f.tar.bz2
thermoprint-7a5a7c49c4e6a3050e21e7ddb8a7ea0870db1c0f.tar.xz
thermoprint-7a5a7c49c4e6a3050e21e7ddb8a7ea0870db1c0f.zip
framework for nix build
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..2d7864a
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,17 @@
1{ pkgs ? (import <nixpkgs> {})
2, compiler ? "ghc7102"
3}:
4
5let
6 ghc = pkgs.haskell.packages.${compiler}.ghcWithPackages (ps: with ps; [
7 cabal-install hlint cabal2nix
8 ] ++ (builtins.attrValues (import ./default.nix {})));
9in
10pkgs.stdenv.mkDerivation rec {
11 name = "thermoprint-env";
12 buildInputs = [ ghc ];
13 shellHook = ''
14 eval $(egrep ^export ${ghc}/bin/ghc)
15 export PROMPT_INFO="${name}"
16 '';
17}