aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2015-09-14 22:07:20 +0000
committerGregor Kleen <gkleen@yggdrasil.li>2015-09-14 22:07:20 +0000
commit3402bbc71d4492caff4098b9606a58ab18ab67c2 (patch)
tree4fe98ac24455da8e07188e4aa803abe05b79af14 /shell.nix
downloadthermoprint-3402bbc71d4492caff4098b9606a58ab18ab67c2.tar
thermoprint-3402bbc71d4492caff4098b9606a58ab18ab67c2.tar.gz
thermoprint-3402bbc71d4492caff4098b9606a58ab18ab67c2.tar.bz2
thermoprint-3402bbc71d4492caff4098b9606a58ab18ab67c2.tar.xz
thermoprint-3402bbc71d4492caff4098b9606a58ab18ab67c2.zip
First shot at basic structure
The planned webapp is missing for now. `nix-build -A servant` fails because thermoprint does not seem to be registered with ghc (see `echo 'import Thermoprint' | nix-shell -p 'ghci'`)
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..df3ed18
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,14 @@
1{ pkgs ? (import <nixpkgs> {})
2, compiler ? "ghc7102"
3}:
4
5let
6 ghc = pkgs.haskell.packages.${compiler}.ghcWithPackages (ps: with ps; [
7 cabal-install hlint cabal2nix
8 ] ++ (builtins.attrValues (import ./default.nix {})));
9in
10pkgs.stdenv.mkDerivation {
11 name = "thermoprinter-env";
12 buildInputs = [ ghc ];
13 shellHook = "eval $(egrep ^export ${ghc}/bin/ghc)";
14}