aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2016-02-18 21:58:28 +0000
committerGregor Kleen <gkleen@yggdrasil.li>2016-02-18 21:58:28 +0000
commit2d16ad6786e6047fc61b34e6bd7e59e794a9d5a3 (patch)
tree949fdf3576f0982b2b023f42f0bfe08caacf9032 /shell.nix
parent9be1df5c047c1cb0f4e1d72feb5c99b86918df80 (diff)
downloadthermoprint-2d16ad6786e6047fc61b34e6bd7e59e794a9d5a3.tar
thermoprint-2d16ad6786e6047fc61b34e6bd7e59e794a9d5a3.tar.gz
thermoprint-2d16ad6786e6047fc61b34e6bd7e59e794a9d5a3.tar.bz2
thermoprint-2d16ad6786e6047fc61b34e6bd7e59e794a9d5a3.tar.xz
thermoprint-2d16ad6786e6047fc61b34e6bd7e59e794a9d5a3.zip
ghc version bump & cleanup
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix13
1 files changed, 6 insertions, 7 deletions
diff --git a/shell.nix b/shell.nix
index 1e9307e..d6f2e43 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,14 +1,13 @@
1{ pkgs ? (import <nixpkgs> {}) 1{ pkgs ? (import <nixpkgs> {})
2, compilerName ? "ghc7102" 2, compilerName ? "ghc7103"
3}: 3}:
4 4
5let 5let
6 packages = ps: with ps; [ 6 thermoprintPackages = builtins.attrValues (import ./default.nix {});
7 cabal-install hlint cabal2nix 7 ghc = pkgs.haskell.packages.${compilerName}.ghcWithPackages
8 hspec QuickCheck quickcheck-instances 8 (ps: thermoprintPackages ++ utilities ps ++ testDeps ps);
9 hspec-contrib temporary 9 utilities = (ps: with ps; [ hlint cabal2nix ]);
10 ] ++ (builtins.attrValues (import ./default.nix { inherit pkgs; })); 10 testDeps = (ps: with ps; [ temporary hspec ]);
11 ghc = pkgs.haskell.packages.${compilerName}.ghcWithPackages packages;
12in 11in
13pkgs.stdenv.mkDerivation rec { 12pkgs.stdenv.mkDerivation rec {
14 name = "thermoprint-env"; 13 name = "thermoprint-env";