aboutsummaryrefslogtreecommitdiff
path: root/server/thermoprint-server.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2016-02-29 22:14:57 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2016-02-29 22:14:57 +0100
commitd07c1cf5d04f802501a98ce986b78d42b7329901 (patch)
treefeac0da36aed47723c3a7b75ad9df24eb5103007 /server/thermoprint-server.nix
parent844f5e96097f8fcced94220487a7c5ad40c1e97f (diff)
downloadthermoprint-d07c1cf5d04f802501a98ce986b78d42b7329901.tar
thermoprint-d07c1cf5d04f802501a98ce986b78d42b7329901.tar.gz
thermoprint-d07c1cf5d04f802501a98ce986b78d42b7329901.tar.bz2
thermoprint-d07c1cf5d04f802501a98ce986b78d42b7329901.tar.xz
thermoprint-d07c1cf5d04f802501a98ce986b78d42b7329901.zip
Further work on QMConfig tools
Diffstat (limited to 'server/thermoprint-server.nix')
-rw-r--r--server/thermoprint-server.nix19
1 files changed, 10 insertions, 9 deletions
diff --git a/server/thermoprint-server.nix b/server/thermoprint-server.nix
index 6ff8b10..ff8ebd4 100644
--- a/server/thermoprint-server.nix
+++ b/server/thermoprint-server.nix
@@ -1,7 +1,7 @@
1{ mkDerivation, async, base, binary, bytestring, conduit 1{ mkDerivation, async, base, binary, bytestring, conduit
2, containers, data-default-class, deepseq, dyre, either, encoding 2, constraints, containers, data-default-class, deepseq, dyre
3, exceptions, extended-reals, filelock, hspec, mmorph 3, either, encoding, exceptions, extended-reals, filelock, hspec
4, monad-control, monad-logger, mtl, network-uri, persistent 4, mmorph, monad-control, monad-logger, mtl, network-uri, persistent
5, persistent-sqlite, persistent-template, QuickCheck 5, persistent-sqlite, persistent-template, QuickCheck
6, quickcheck-instances, resourcet, servant, servant-server, stdenv 6, quickcheck-instances, resourcet, servant, servant-server, stdenv
7, stm, temporary, text, thermoprint-client, thermoprint-spec, time 7, stm, temporary, text, thermoprint-client, thermoprint-spec, time
@@ -14,12 +14,13 @@ mkDerivation {
14 isLibrary = true; 14 isLibrary = true;
15 isExecutable = true; 15 isExecutable = true;
16 libraryHaskellDepends = [ 16 libraryHaskellDepends = [
17 base binary bytestring conduit containers data-default-class 17 base binary bytestring conduit constraints containers
18 deepseq dyre either encoding exceptions extended-reals filelock 18 data-default-class deepseq dyre either encoding exceptions
19 mmorph monad-control monad-logger mtl network-uri persistent 19 extended-reals filelock mmorph monad-control monad-logger mtl
20 persistent-template QuickCheck quickcheck-instances resourcet 20 network-uri persistent persistent-template QuickCheck
21 servant servant-server stm text thermoprint-spec time transformers 21 quickcheck-instances resourcet servant servant-server stm text
22 wai wai-websockets warp websockets 22 thermoprint-spec time transformers wai wai-websockets warp
23 websockets
23 ]; 24 ];
24 executableHaskellDepends = [ 25 executableHaskellDepends = [
25 base monad-logger mtl persistent-sqlite resourcet 26 base monad-logger mtl persistent-sqlite resourcet