aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2016-02-19 14:21:47 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2016-02-19 14:21:47 +0100
commit9585d245212572b2c599b3c10cfba545e42f46d1 (patch)
tree5b503edccfccf2b9f694460af69e72f06a30e93b /default.nix
parenta6fafcc31f81b12bcffebec77cbba80aa422671d (diff)
downloadthermoprint-9585d245212572b2c599b3c10cfba545e42f46d1.tar
thermoprint-9585d245212572b2c599b3c10cfba545e42f46d1.tar.gz
thermoprint-9585d245212572b2c599b3c10cfba545e42f46d1.tar.bz2
thermoprint-9585d245212572b2c599b3c10cfba545e42f46d1.tar.xz
thermoprint-9585d245212572b2c599b3c10cfba545e42f46d1.zip
Unified ghc version used across build
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix14
1 files changed, 8 insertions, 6 deletions
diff --git a/default.nix b/default.nix
index 52ecd20..1dc1708 100644
--- a/default.nix
+++ b/default.nix
@@ -1,19 +1,21 @@
1{ pkgs ? (import <nixpkgs> {}) 1{ pkgs ? (import <nixpkgs> {})
2, compilerName ? "ghc7103"
2}: 3}:
3 4
4rec { 5rec {
5 thermoprint-spec = pkgs.haskellPackages.callPackage ./spec/thermoprint-spec.nix {}; 6 haskellPackages = pkgs.haskell.packages."${compilerName}";
6 thermoprint-bbcode = pkgs.haskellPackages.callPackage ./tp-bbcode/thermoprint-bbcode.nix { 7 thermoprint-spec = haskellPackages.callPackage ./spec/thermoprint-spec.nix {};
8 thermoprint-bbcode = haskellPackages.callPackage ./tp-bbcode/thermoprint-bbcode.nix {
7 inherit bbcode thermoprint-spec; 9 inherit bbcode thermoprint-spec;
8 }; 10 };
9 thermoprint-client = pkgs.haskellPackages.callPackage ./client/thermoprint-client.nix { 11 thermoprint-client = haskellPackages.callPackage ./client/thermoprint-client.nix {
10 inherit thermoprint-spec; 12 inherit thermoprint-spec;
11 }; 13 };
12 thermoprint-server = pkgs.callPackage ./server/wrapped.nix { 14 thermoprint-server = pkgs.callPackage ./server/wrapped.nix {
13 inherit (pkgs.haskellPackages) ghcWithPackages; 15 inherit (haskellPackages) ghcWithPackages;
14 thermoprint-server = pkgs.haskellPackages.callPackage ./server/thermoprint-server.nix { 16 thermoprint-server = haskellPackages.callPackage ./server/thermoprint-server.nix {
15 inherit thermoprint-spec thermoprint-client; 17 inherit thermoprint-spec thermoprint-client;
16 }; 18 };
17 }; 19 };
18 bbcode = pkgs.haskellPackages.callPackage ./bbcode/bbcode.nix {}; 20 bbcode = haskellPackages.callPackage ./bbcode/bbcode.nix {};
19} 21}