aboutsummaryrefslogtreecommitdiff
path: root/client/shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2016-02-17 23:46:48 +0000
committerGregor Kleen <gkleen@yggdrasil.li>2016-02-17 23:46:48 +0000
commit072d7ad172d114121ae0d50f8c7841ace9699965 (patch)
treece42a9c3fc4210b84e77f5f50a109339d4ba3772 /client/shell.nix
parent39ae58ddbe3f59f99e4ce2e3d68cfdbccaaec202 (diff)
downloadthermoprint-072d7ad172d114121ae0d50f8c7841ace9699965.tar
thermoprint-072d7ad172d114121ae0d50f8c7841ace9699965.tar.gz
thermoprint-072d7ad172d114121ae0d50f8c7841ace9699965.tar.bz2
thermoprint-072d7ad172d114121ae0d50f8c7841ace9699965.tar.xz
thermoprint-072d7ad172d114121ae0d50f8c7841ace9699965.zip
Started work on client library
Diffstat (limited to 'client/shell.nix')
-rw-r--r--client/shell.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/client/shell.nix b/client/shell.nix
new file mode 100644
index 0000000..1e9307e
--- /dev/null
+++ b/client/shell.nix
@@ -0,0 +1,20 @@
1{ pkgs ? (import <nixpkgs> {})
2, compilerName ? "ghc7102"
3}:
4
5let
6 packages = ps: with ps; [
7 cabal-install hlint cabal2nix
8 hspec QuickCheck quickcheck-instances
9 hspec-contrib temporary
10 ] ++ (builtins.attrValues (import ./default.nix { inherit pkgs; }));
11 ghc = pkgs.haskell.packages.${compilerName}.ghcWithPackages packages;
12in
13pkgs.stdenv.mkDerivation rec {
14 name = "thermoprint-env";
15 buildInputs = [ ghc ];
16 shellHook = ''
17 eval $(egrep ^export ${ghc}/bin/ghc)
18 export PROMPT_INFO="${name}"
19 '';
20}