summaryrefslogtreecommitdiff
path: root/RCade.nix
diff options
context:
space:
mode:
Diffstat (limited to 'RCade.nix')
-rw-r--r--RCade.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/RCade.nix b/RCade.nix
new file mode 100644
index 0000000..ec21960
--- /dev/null
+++ b/RCade.nix
@@ -0,0 +1,23 @@
1{ stdenv
2, SDL
3, SDL_ttf
4, SDL_image
5, SDL_gfx
6, SDL_mixer
7}:
8
9stdenv.mkDerivation {
10 name = "RCade";
11 src = ./.;
12
13 buildInputs = [ SDL SDL_ttf SDL_image SDL_gfx SDL_mixer ];
14
15 preConfigure = ''
16 export NIX_CFLAGS_COMPILE="$NIX_CFLAGS_COMPILE -I${SDL}/include/SDL"
17 '';
18
19 installPhase = ''
20 mkdir -p $out/bin
21 install -m 555 Game $out/bin
22 '';
23}