diff options
Diffstat (limited to 'ymir/mlmmj-expose.nix')
-rw-r--r-- | ymir/mlmmj-expose.nix | 7 |
1 files changed, 6 insertions, 1 deletions
diff --git a/ymir/mlmmj-expose.nix b/ymir/mlmmj-expose.nix index 8c7dfb91..b8a13cc4 100644 --- a/ymir/mlmmj-expose.nix +++ b/ymir/mlmmj-expose.nix | |||
@@ -43,7 +43,12 @@ let | |||
43 | case hashes of | 43 | case hashes of |
44 | [((_, recipient), _)] -> do | 44 | [((_, recipient), _)] -> do |
45 | uuid <- UUID.nextRandom | 45 | uuid <- UUID.nextRandom |
46 | let fName = "queue" </> "exposed" <.> UUID.toString uuid | 46 | let fName = "queue" </> "exposed" <.> uuidTrans uuid |
47 | uuidTrans = uuidTrans' . UUID.toString | ||
48 | where | ||
49 | uuidTrans' [] = [] | ||
50 | uuidTrans' ('-':xs) = '.' : uuidTrans' xs | ||
51 | uuidTrans' (x:xs) = x : uuidTrans' xs | ||
47 | getContents >>= writeFile fName | 52 | getContents >>= writeFile fName |
48 | hPrintf stdout "Forwarding mail to <%s>, subscribed to %s\n" recipient (takeBaseName listDir) | 53 | hPrintf stdout "Forwarding mail to <%s>, subscribed to %s\n" recipient (takeBaseName listDir) |
49 | callProcess "${pkgs.mlmmj}/bin/mlmmj-send" ["-L", listDir, "-l", "6", "-m", fName, "-T", recipient] | 54 | callProcess "${pkgs.mlmmj}/bin/mlmmj-send" ["-L", listDir, "-l", "6", "-m", fName, "-T", recipient] |