summaryrefslogtreecommitdiff
path: root/ymir/mlmmj-expose.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ymir/mlmmj-expose.nix')
-rw-r--r--ymir/mlmmj-expose.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/ymir/mlmmj-expose.nix b/ymir/mlmmj-expose.nix
index 13f119c0..a69c6bb2 100644
--- a/ymir/mlmmj-expose.nix
+++ b/ymir/mlmmj-expose.nix
@@ -75,7 +75,7 @@ let
75 getSubscribers :: IO [String] 75 getSubscribers :: IO [String]
76 getSubscribers = map (map toLower) . concat <$> mapM (flip catchIOError (\e -> if isDoesNotExistError e then return [] else ioError e) . readDir) ["subscribers.d", "digesters.d"] 76 getSubscribers = map (map toLower) . concat <$> mapM (flip catchIOError (\e -> if isDoesNotExistError e then return [] else ioError e) . readDir) ["subscribers.d", "digesters.d"]
77 where 77 where
78 readDir dir = concat <$> (mapM (fmap lines . readFile) . map (dir </>) =<< (listDirectory dir)) 78 readDir dir = concat <$> (mapM (fmap lines . readFile) . map (dir </>) . filter (not . (`elem` [".", ".."]))=<< (getDirectoryContents dir))
79 ''; 79 '';
80 buildCommand = '' 80 buildCommand = ''
81 mkdir -p $out/bin 81 mkdir -p $out/bin