summaryrefslogtreecommitdiff
path: root/ymir.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ymir.nix')
-rw-r--r--ymir.nix28
1 files changed, 26 insertions, 2 deletions
diff --git a/ymir.nix b/ymir.nix
index 04858dad..c5902f9a 100644
--- a/ymir.nix
+++ b/ymir.nix
@@ -570,12 +570,36 @@ in rec {
570 masterConfig = { 570 masterConfig = {
571 uucp = { 571 uucp = {
572 type = "unix"; 572 type = "unix";
573 private = true; 573 private = null;
574 privileged = false; 574 privileged = true;
575 chroot = false; 575 chroot = false;
576 command = "pipe"; 576 command = "pipe";
577 args = [ "flags=Fqhu" "user=uucp" ''argv=${config.security.wrapperDir}/uux -z -a $sender - $nexthop!rmail ($recipient)'' ]; 577 args = [ "flags=Fqhu" "user=uucp" ''argv=${config.security.wrapperDir}/uux -z -a $sender - $nexthop!rmail ($recipient)'' ];
578 }; 578 };
579 mlmmj = {
580 type = "unix";
581 private = null;
582 privileged = true;
583 chroot = false;
584 command = "pipe";
585 args = [ "flags=ORhu" "user=mlmmj" ''argv=${pkgs.mlmmj}/bin/mlmmj-receive -F -L /var/spool/lists/''${user}'' ];
586 };
587 mlmmj-subs = {
588 type = "unix";
589 private = null;
590 privileged = true;
591 chroot = false;
592 command = "pipe";
593 args = [ "flags=Fqhu" "user=uucp" ''argv=${pkgs.mlmmj-exposed}/bin/mlmmj-exposed /var/spool/lists/''${user} ''${extension}'' ];
594 };
595 policy-spf = {
596 type = "unix";
597 private = null;
598 privileged = true;
599 chroot = false;
600 command = "spawn";
601 args = [ "user=nobody" ''argv=${pkgs.pythonPackages.pypolicyd-spf}/bin/policyd-spf ${./ymir/spf.conf}'' ];
602 };
579 }; 603 };
580 # extraMasterConf = '' 604 # extraMasterConf = ''
581 # uucp unix - n n - - pipe flags=Fqhu user=uucp argv=${config.security.wrapperDir}/uux -z -a $sender - $nexthop!rmail ($recipient) 605 # uucp unix - n n - - pipe flags=Fqhu user=uucp argv=${config.security.wrapperDir}/uux -z -a $sender - $nexthop!rmail ($recipient)