summaryrefslogtreecommitdiff
path: root/ymir.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ymir.nix')
-rw-r--r--ymir.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/ymir.nix b/ymir.nix
index 8a17cfe4..7895a859 100644
--- a/ymir.nix
+++ b/ymir.nix
@@ -21,6 +21,7 @@ in rec {
21 ./users.nix 21 ./users.nix
22 ./custom/tinc/def.nix 22 ./custom/tinc/def.nix
23 ./custom/ymir-nginx.nix 23 ./custom/ymir-nginx.nix
24 ./custom/uucp.nix
24 ]; 25 ];
25 26
26 boot.loader.grub = { 27 boot.loader.grub = {
@@ -85,6 +86,7 @@ in rec {
85 rsync 86 rsync
86 tmux 87 tmux
87 zsh 88 zsh
89 uucp
88 ]; 90 ];
89 91
90 networking = { 92 networking = {
@@ -315,7 +317,21 @@ in rec {
315 #enable TLS logging to see the ciphers for outbound connections 317 #enable TLS logging to see the ciphers for outbound connections
316 smtp_tls_loglevel = 1 318 smtp_tls_loglevel = 1
317 ''; 319 '';
320 extraMasterConf = ''
321 uucp unix - n n - - pipe flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
322 '';
323 };
324 users.extraUsers."uucp" = {
325 createHome = true;
326 home = "/var/spool/uucp";
327 isSystemUser = true;
328 isNormalUser = false;
329 openssh.authorizedKeys.keyFiles = [
330 users/keys/gkleen-skadhi.pub
331 users/keys/gkleen-vali.pub
332 ];
318 }; 333 };
334 environment.etc."/etc/uucp/call"
319 335
320 security.acme = { 336 security.acme = {
321 certs = { 337 certs = {
@@ -333,4 +349,8 @@ in rec {
333 }; 349 };
334 }; 350 };
335 }; 351 };
352
353 services.uucp = {
354 enable = true;
355 };
336} 356}