summaryrefslogtreecommitdiff
path: root/ymir.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ymir.nix')
-rw-r--r--ymir.nix14
1 files changed, 2 insertions, 12 deletions
diff --git a/ymir.nix b/ymir.nix
index 773b5a71..8a17cfe4 100644
--- a/ymir.nix
+++ b/ymir.nix
@@ -9,11 +9,10 @@ let
9 enabled = true; 9 enabled = true;
10 domain = name; 10 domain = name;
11 ssl = { 11 ssl = {
12 key = "/etc/ssl/self/${name}/key.pem"; 12 key = "/var/lib/acme/yggdrasil.li/key.pem";
13 cert = "/etc/ssl/self/${name}/fullchain.pem"; 13 cert = "/var/lib/acme/yggdrasil.li/fullchain.pem";
14 }; 14 };
15 }; 15 };
16 simp_le = pkgs.callPackage ./custom/simp_le.nix {};
17in rec { 16in rec {
18 imports = 17 imports =
19 [ 18 [
@@ -142,15 +141,6 @@ in rec {
142 enable = true; 141 enable = true;
143 systab = '' 142 systab = ''
144 %weekly * * nix-collect-garbage --delete-older-than '7d' 143 %weekly * * nix-collect-garbage --delete-older-than '7d'
145 %monthly * * * ${simp_le "git.yggdrasil.li"}
146 %monthly * * * ${simp_le "dirty-haskell.org"}
147 %monthly * * * ${simp_le "www.dirty-haskell.org"}
148 %monthly * * * ${simp_le "141.li"}
149 %monthly * * * ${simp_le "xmpp.li"}
150 %monthly * * * ${simp_le "yggdrasil.li"}
151 %monthly * * * ${simp_le "praseodym.org"}
152 %daily * * systemctl reload nginx.service
153 %daily * * prosodyctl reload
154 ''; 144 '';
155 }; 145 };
156 146