summaryrefslogtreecommitdiff
path: root/vali.nix
diff options
context:
space:
mode:
Diffstat (limited to 'vali.nix')
-rw-r--r--vali.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/vali.nix b/vali.nix
index a1948421..500aa66b 100644
--- a/vali.nix
+++ b/vali.nix
@@ -161,4 +161,23 @@ rec {
161 HibernateMode=shutdown platform 161 HibernateMode=shutdown platform
162 ''; 162 '';
163 }; 163 };
164
165 systemd.automounts= [
166 { enable = true;
167 automountConfig = {
168 Where = "/var/media";
169 DirectoryMode = "555";
170 };
171 }
172 ];
173
174 systemd.mounts = [
175 { enable = true;
176 What = "gkleen@hel.asgard.yggdrasil:/var/media";
177 Where = "/var/media";
178 Type = "fuse.sshfs";
179 Options = "users,idmap=gkleen,IdentityFile=/home/user/.ssh/id_ed25519,allow_other,reconnect,_netdev";
180 DirectoryMode = "555";
181 }
182 ];
164} 183}