summaryrefslogtreecommitdiff
path: root/vali-hw.nix
diff options
context:
space:
mode:
Diffstat (limited to 'vali-hw.nix')
-rw-r--r--vali-hw.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/vali-hw.nix b/vali-hw.nix
new file mode 100644
index 00000000..700c82ee
--- /dev/null
+++ b/vali-hw.nix
@@ -0,0 +1,35 @@
1# Do not modify this file! It was generated by ‘nixos-generate-config’
2# and may be overwritten by future invocations. Please make changes
3# to /etc/nixos/configuration.nix instead.
4{ config, lib, pkgs, ... }:
5
6{
7 imports =
8 [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
9 ];
10
11 boot.initrd.availableKernelModules = [ "ehci_pci" "ata_piix" "pata_marvell" "xhci_hcd" "firewire_ohci" "usb_storage" "usbhid" ];
12 boot.kernelModules = [ "kvm-intel" ];
13 boot.extraModulePackages = [ ];
14
15 fileSystems."/" =
16 { device = "/dev/disk/by-uuid/2343160f-7abc-4233-8dac-3b42ad0fdadb";
17 fsType = "ext4";
18 };
19
20 fileSystems."/home" =
21 { device = "/dev/disk/by-uuid/044567e1-f652-4fe2-b1bf-d5052a49fb6b";
22 fsType = "ext4";
23 };
24
25 fileSystems."/boot" =
26 { device = "/dev/disk/by-uuid/5aa9e2b4-9342-4144-8423-6c35bb3da991";
27 fsType = "ext2";
28 };
29
30 swapDevices =
31 [ { device = "/dev/disk/by-uuid/53fd36a6-9d1e-4316-ac21-8d38d89753ac"; }
32 ];
33
34 nix.maxJobs = 8;
35}