summaryrefslogtreecommitdiff
path: root/users/gkleen@odin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/gkleen@odin.nix')
-rw-r--r--users/gkleen@odin.nix28
1 files changed, 20 insertions, 8 deletions
diff --git a/users/gkleen@odin.nix b/users/gkleen@odin.nix
index 1ff0e7be..6103801a 100644
--- a/users/gkleen@odin.nix
+++ b/users/gkleen@odin.nix
@@ -9,13 +9,25 @@
9 sha256 = "02a4py7zx9ib49kijpjckya1pb8xlb3gmp7s1dybsdjmwqbdyzx7"; 9 sha256 = "02a4py7zx9ib49kijpjckya1pb8xlb3gmp7s1dybsdjmwqbdyzx7";
10 }; 10 };
11 }); 11 });
12 buchhaltung = pkgs.haskell.lib.overrideCabal pkgs.haskell.packages."ghc802".buchhaltung (oldAttrs: { 12
13 buildDepends = oldAttrs.buildDepends or [] ++ [ pkgs.makeWrapper ]; 13 haskell = pkgs.haskell // {
14 postBuild = '' 14 packages = pkgs.haskell.packages // {
15 ${oldAttrs.postBuild or ""} 15 ghc822 = pkgs.haskell.packages.ghc822.extend (selfH: superH: {
16 wrapProgram $out/bin/buchhaltung \ 16 ListLike = pkgs.haskell.lib.overrideCabal superH.ListLike (oldAttrs: {
17 --prefix PATH : ${pkgs.lib.makeBinPath (with pkgs; [ aqbanking dbacl ])} 17 nativeBuildInputs = oldAttrs.nativeBuildInputs or [] ++ with selfH; semigroups;
18 ''; 18 });
19 }); 19 buchhaltung = pkgs.haskell.lib.overrideCabal superH.buchhaltung (oldAttrs: {
20 buildDepends = oldAttrs.buildDepends or [] ++ [ pkgs.makeWrapper ];
21 postBuild = ''
22 ${oldAttrs.postBuild or ""}
23 wrapProgram $out/bin/buchhaltung \
24 --prefix PATH : ${pkgs.lib.makeBinPath (with pkgs; [ aqbanking dbacl ])}
25 '';
26 });
27 };
28 };
29 };
30
31 inherit (pkgs.haskell.ghc822.packages) buchhaltung;
20 } // (import ../utils/nix/default.nix) pkgs (import <nixpkgs> {}); 32 } // (import ../utils/nix/default.nix) pkgs (import <nixpkgs> {});
21} 33}