summaryrefslogtreecommitdiff
path: root/users/gkleen/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/gkleen/default.nix')
-rw-r--r--users/gkleen/default.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/users/gkleen/default.nix b/users/gkleen/default.nix
index 03e4a64b..f74701a5 100644
--- a/users/gkleen/default.nix
+++ b/users/gkleen/default.nix
@@ -1,7 +1,15 @@
1{ userName, pkgs, ... }: 1{ userName, pkgs, customUtils, lib, ... }:
2{ 2{
3 users.users.${userName} = { 3 users.users.${userName} = {
4 description = "Gregor Kleen";
5 extraGroups = [ "wheel" "networkmanager" "lp" "dialout" "audio" "video" "xmpp" "mail" "ssh" "vboxusers" "libvirtd" "wireshark" "games"];
6 group = "users";
7 uid = 1000;
8 createHome = true;
9 home = "/home/${userName}";
10 shell = "${pkgs.zsh}/bin/zsh";
11 isNormalUser = true;
12 openssh.authorizedKeys.keyFiles = lib.attrValues (customUtils.recImport rec { dir = ./authorized-keys; _import = name: _base: dir + "/${name}"; });
4 hashedPassword = "$6$rounds=500000$dOMgCU7DAk$yQFYGOURTEt12387LIYBnFKSWmtwXMUk1LJWnV0m7OFt.y2TnxQn2abdGA5dhwG9EmMB5wZGXf4J5F71c746C/"; 13 hashedPassword = "$6$rounds=500000$dOMgCU7DAk$yQFYGOURTEt12387LIYBnFKSWmtwXMUk1LJWnV0m7OFt.y2TnxQn2abdGA5dhwG9EmMB5wZGXf4J5F71c746C/";
5 extraGroups = ["wheel" "networkmanager"];
6 }; 14 };
7} 15}