summaryrefslogtreecommitdiff
path: root/user-profiles/core.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user-profiles/core.nix')
-rw-r--r--user-profiles/core.nix14
1 files changed, 1 insertions, 13 deletions
diff --git a/user-profiles/core.nix b/user-profiles/core.nix
index ea782a4b..a8af48b3 100644
--- a/user-profiles/core.nix
+++ b/user-profiles/core.nix
@@ -5,19 +5,7 @@ with lib;
5{ 5{
6 config = { 6 config = {
7 users.users.${userName} = {}; # Just make sure the user is created 7 users.users.${userName} = {}; # Just make sure the user is created
8 8 home-manager.users.${userName} = {};
9 home-manager.useUserService = true;
10 home-manager.extraSpecialArgs = { inherit flake flakeInputs path; };
11 home-manager.users.${userName} = {
12 imports = lib.attrValues flake.homeModules;
13
14 config = {
15 manual.manpages.enable = true;
16 systemd.user.startServices = "sd-switch";
17
18 programs.ssh.internallyManaged = mkForce true;
19 };
20 };
21 9
22 systemd.services."home-manager-${utils.escapeSystemdPath userName}" = lib.mkIf (!config.home-manager.enableSystemd) { 10 systemd.services."home-manager-${utils.escapeSystemdPath userName}" = lib.mkIf (!config.home-manager.enableSystemd) {
23 restartIfChanged = false; # only run once on startup, deploy to running system with deploy-rs 11 restartIfChanged = false; # only run once on startup, deploy to running system with deploy-rs