summaryrefslogtreecommitdiff
path: root/sif/hw.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sif/hw.nix')
-rw-r--r--sif/hw.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/sif/hw.nix b/sif/hw.nix
new file mode 100644
index 00000000..17293c90
--- /dev/null
+++ b/sif/hw.nix
@@ -0,0 +1,33 @@
1{ config, lib, pkgs, ... }:
2
3{
4 imports =
5 [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
6 ];
7
8 fileSystems."/" =
9 { device = "/dev/disk/by-uuid/f094bf06-66f9-40a8-9ab2-2b54d05223d2";
10 fsType = "btrfs";
11 };
12
13 fileSystems."/boot" =
14 { device = "/dev/disk/by-uuid/B3A2-D029";
15 fsType = "vfat";
16 };
17
18 fileSystems."/home" =
19 { device = "/dev/disk/by-uuid/9e932072-3c56-4a9c-8da7-3163d2a8bf28";
20 fsType = "btrfs";
21 };
22
23 swapDevices =
24 [ { device = "/dev/disk/by-uuid/50f3f856-cc17-4614-846a-34a14d5006ec"; }
25 ];
26
27 nix.maxJobs = lib.mkDefault 12;
28 powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
29 # High-DPI console
30 i18n.consoleFont = lib.mkDefault "${pkgs.terminus_font}/share/consolefonts/ter-u28n.psf.gz";
31
32 hardware.cpu.intel.updateMicrocode = true;
33}