summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
index ad10de87..a8239dc8 100644
--- a/shell.nix
+++ b/shell.nix
@@ -8,6 +8,10 @@ let
8 wrapProgram $out/bin/nix --add-flags '--option experimental-features "nix-command flakes"' 8 wrapProgram $out/bin/nix --add-flags '--option experimental-features "nix-command flakes"'
9 ''; 9 '';
10 }; 10 };
11
12 tai64dec = pkgs.writeShellScriptBin "tai64dec" ''
13 echo $((16#$(${pkgs.daemontools}/bin/tai64n <<<"" | ${pkgs.coreutils}/bin/tail -c +2 | ${pkgs.coreutils}/bin/head -c 16)))
14 '';
11in pkgs.mkShell { 15in pkgs.mkShell {
12 name = "nixos"; 16 name = "nixos";
13 nativeBuildInputs = with pkgs; [ 17 nativeBuildInputs = with pkgs; [
@@ -17,5 +21,6 @@ in pkgs.mkShell {
17 gup 21 gup
18 nftables 22 nftables
19 deploy-rs 23 deploy-rs
24 tai64dec
20 ]; 25 ];
21} 26}