diff options
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 16 |
1 files changed, 16 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix new file mode 100644 index 00000000..2820eb1a --- /dev/null +++ b/shell.nix | |||
@@ -0,0 +1,16 @@ | |||
1 | { pkgs ? import <nixpkgs> {} }: | ||
2 | let | ||
3 | nixWithFlakes = pkgs.symlinkJoin { | ||
4 | name = "nix-with-flakes"; | ||
5 | paths = [ pkgs.nixFlakes ]; | ||
6 | buildInputs = [ pkgs.makeWrapper ]; | ||
7 | postBuild = '' | ||
8 | wrapProgram $out/bin/nix --add-flags '--option experimental-features "nix-command flakes ca-references"' | ||
9 | ''; | ||
10 | }; | ||
11 | in pkgs.mkShell { | ||
12 | name = "nixos"; | ||
13 | nativeBuildInputs = with pkgs; [ | ||
14 | nixWithFlakes | ||
15 | ]; | ||
16 | } | ||