diff options
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 4 |
1 files changed, 1 insertions, 3 deletions
@@ -3,11 +3,9 @@ let | |||
3 | pkgs = self.legacyPackages.${system}; | 3 | pkgs = self.legacyPackages.${system}; |
4 | utils = import ./utils { inherit (nixpkgs) lib; }; | 4 | utils = import ./utils { inherit (nixpkgs) lib; }; |
5 | inherit (utils) nixImport; | 5 | inherit (utils) nixImport; |
6 | |||
7 | tools = nixImport rec { dir = ./tools; _import = _path: name: import "${toString dir}/${name}" inputs; }; | ||
8 | in pkgs.mkShell { | 6 | in pkgs.mkShell { |
9 | name = "nixos"; | 7 | name = "nixos"; |
10 | nativeBuildInputs = builtins.attrValues tools ++ (with pkgs; [ | 8 | nativeBuildInputs = builtins.attrValues self.packages.${system} ++ (with pkgs; [ |
11 | sops | 9 | sops |
12 | wireguard-tools | 10 | wireguard-tools |
13 | gup | 11 | gup |