summaryrefslogtreecommitdiff
path: root/overlays/worktime/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/worktime/pyproject.toml')
-rw-r--r--overlays/worktime/pyproject.toml36
1 files changed, 18 insertions, 18 deletions
diff --git a/overlays/worktime/pyproject.toml b/overlays/worktime/pyproject.toml
index de4b9fd4..bb6934ac 100644
--- a/overlays/worktime/pyproject.toml
+++ b/overlays/worktime/pyproject.toml
@@ -1,23 +1,23 @@
1[tool.poetry] 1[project]
2name = "worktime" 2name = "worktime"
3version = "0.1.0" 3version = "1.0.0"
4description = "" 4requires-python = "~=3.12"
5authors = ["Gregor Kleen <gkleen@yggdrasil.li>"] 5dependencies = [
6 "pyxdg>=0.28,<0.29",
7 "python-dateutil>=2.9.0.post0,<3",
8 "uritools>=4.0.3,<5",
9 "requests>=2.32.3,<3",
10 "tabulate>=0.9.0,<0.10",
11 "toml>=0.10.2,<0.11",
12 "jsonpickle>=4.0.5,<5",
13]
6 14
7[tool.poetry.dependencies] 15[project.scripts]
8python = "^3.12"
9pyxdg = "^0.28"
10python-dateutil = "^2.9.0.post0"
11uritools = "^4.0.3"
12requests = "^2.32.3"
13tabulate = "^0.9.0"
14backoff = "^2.2.1"
15toml = "^0.10.2"
16jsonpickle = "^4.0.5"
17
18[tool.poetry.scripts]
19worktime = "worktime.__main__:main" 16worktime = "worktime.__main__:main"
20 17
21[build-system] 18[build-system]
22requires = ["poetry-core"] 19requires = ["hatchling"]
23build-backend = "poetry.core.masonry.api" \ No newline at end of file 20build-backend = "hatchling.build"
21
22[dependency-groups]
23dev = []