diff options
Diffstat (limited to 'overlays/spm/spm.nix')
-rw-r--r-- | overlays/spm/spm.nix | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/overlays/spm/spm.nix b/overlays/spm/spm.nix new file mode 100644 index 00000000..533f190a --- /dev/null +++ b/overlays/spm/spm.nix | |||
@@ -0,0 +1,31 @@ | |||
1 | { mkDerivation, aeson, attoparsec, base, bytestring | ||
2 | , case-insensitive, cryptonite, exceptions, file-embed, filepath | ||
3 | , hpack, http-api-data, http-types, jose, lens, lens-aeson, lib | ||
4 | , mmorph, monad-logger, MonadRandom, mtl, optparse-applicative | ||
5 | , path-pieces, persistent, persistent-postgresql, random | ||
6 | , resource-pool, servant, servant-server, template-haskell, text | ||
7 | , th-lift-instances, time, transformers, unliftio-core, uuid | ||
8 | , vector, wai, wai-app-static, wai-extra, warp, warp-systemd | ||
9 | }: | ||
10 | mkDerivation { | ||
11 | pname = "spm"; | ||
12 | version = "0.1.0"; | ||
13 | src = ./.; | ||
14 | isLibrary = true; | ||
15 | isExecutable = true; | ||
16 | libraryHaskellDepends = [ | ||
17 | aeson base case-insensitive jose lens servant text uuid | ||
18 | ]; | ||
19 | libraryToolDepends = [ hpack ]; | ||
20 | executableHaskellDepends = [ | ||
21 | aeson attoparsec base bytestring case-insensitive cryptonite | ||
22 | exceptions file-embed filepath http-api-data http-types jose lens | ||
23 | lens-aeson mmorph monad-logger MonadRandom mtl optparse-applicative | ||
24 | path-pieces persistent persistent-postgresql random resource-pool | ||
25 | servant-server template-haskell text th-lift-instances time | ||
26 | transformers unliftio-core uuid vector wai wai-app-static wai-extra | ||
27 | warp warp-systemd | ||
28 | ]; | ||
29 | prePatch = "hpack"; | ||
30 | license = lib.licenses.agpl3Plus; | ||
31 | } | ||