summaryrefslogtreecommitdiff
path: root/odin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'odin.nix')
-rw-r--r--odin.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/odin.nix b/odin.nix
index cdb0959c..698f71eb 100644
--- a/odin.nix
+++ b/odin.nix
@@ -494,6 +494,7 @@
494 "/bar/".proxyPass = "http://bar/"; 494 "/bar/".proxyPass = "http://bar/";
495 "/motion/cat-food.mjpeg".proxyPass = "http://localhost:8080/"; 495 "/motion/cat-food.mjpeg".proxyPass = "http://localhost:8080/";
496 "/motion/living-room.mjpeg".proxyPass = "http://localhost:8081/"; 496 "/motion/living-room.mjpeg".proxyPass = "http://localhost:8081/";
497 "/prometheus".proxyPass = "http://prometheus";
497 }; 498 };
498 }; 499 };
499 500
@@ -501,6 +502,9 @@
501 "bar" = { 502 "bar" = {
502 servers."localhost:${toString config.services.bar.port}"= {}; 503 servers."localhost:${toString config.services.bar.port}"= {};
503 }; 504 };
505 "prometheus" = {
506 servers."${config.services.prometheus.listenAddress}" = {};
507 };
504 }; 508 };
505 }; 509 };
506 510