summaryrefslogtreecommitdiff
path: root/odin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'odin.nix')
-rw-r--r--odin.nix20
1 files changed, 6 insertions, 14 deletions
diff --git a/odin.nix b/odin.nix
index 34ad166e..cddbb5a4 100644
--- a/odin.nix
+++ b/odin.nix
@@ -64,16 +64,12 @@
64 allowPing = true; 64 allowPing = true;
65 allowedTCPPorts = [ 22 # ssh 65 allowedTCPPorts = [ 22 # ssh
66 139 445 # samba 66 139 445 # samba
67 111 2049 # nfs
68 ]; 67 ];
69 allowedTCPPortRanges = [ { from = 8080; to = 8080; } # motion 68 allowedTCPPortRanges = [ { from = 8080; to = 8080; } # motion
70 { from = 4000; to = 4002; } # nfs
71 ]; 69 ];
72 allowedUDPPorts = [ 137 138 # samba 70 allowedUDPPorts = [ 137 138 # samba
73 111 2049 # nfs
74 ]; 71 ];
75 allowedUDPPortRanges = [ { from = 60000; to = 61000; } # mosh 72 allowedUDPPortRanges = [ { from = 60000; to = 61000; } # mosh
76 { from = 4000; to = 4002; } # nfs
77 ]; 73 ];
78 }; 74 };
79 75
@@ -208,6 +204,12 @@
208 writable = true; 204 writable = true;
209 path = "/srv/eos"; 205 path = "/srv/eos";
210 }; 206 };
207
208 media = {
209 browseable = true;
210 writable = false;
211 path = "/srv/media";
212 };
211 }; 213 };
212 extraConfig = '' 214 extraConfig = ''
213 domain master = true 215 domain master = true
@@ -299,16 +301,6 @@
299 members = [ "motion" ]; 301 members = [ "motion" ];
300 }; 302 };
301 303
302 services.nfs.server = {
303 enable = true;
304 exports = ''
305 /srv/media *(ro,insecure,all_squash,no_subtree_check,mp)
306 '';
307 lockdPort = 4001;
308 mountdPort = 4002;
309 statdPort = 4000;
310 };
311
312 virtualisation.libvirtd = { 304 virtualisation.libvirtd = {
313 enable = true; 305 enable = true;
314 }; 306 };