summaryrefslogtreecommitdiff
path: root/odin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'odin.nix')
-rw-r--r--odin.nix55
1 files changed, 55 insertions, 0 deletions
diff --git a/odin.nix b/odin.nix
new file mode 100644
index 00000000..21054dbc
--- /dev/null
+++ b/odin.nix
@@ -0,0 +1,55 @@
1# Edit this configuration file to define what should be installed on
2# your system. Help is available in the configuration.nix(5) man page
3# and in the NixOS manual (accessible by running ‘nixos-help’).
4
5{ config, pkgs, ... }:
6
7{
8 imports =
9 [ # Include the results of the hardware scan.
10 ./odin/hw.nix
11 ];
12
13 # Use the GRUB 2 boot loader.
14 boot.loader.grub.enable = true;
15 boot.loader.grub.version = 2;
16 # Define on which hard drive you want to install Grub.
17 boot.loader.grub.device = "/dev/disk/by-id/ata-MKNSSDCR60GB_MK130619AS1031770";
18
19 networking.hostName = "odin"; # Define your hostname.
20
21 # Select internationalisation properties.
22 i18n = {
23 consoleKeyMap = "dvp";
24 defaultLocale = "en_US.UTF-8";
25 };
26
27 # Set your time zone.
28 time.timeZone = "Europe/Berlin";
29
30 environment.systemPackages = with pkgs; [
31 pythonPackages.magic-wormhole
32 tmux
33 mosh
34 ];
35
36 programs.zsh.enable = true;
37
38 services.openssh.enable = true;
39
40 networking.firewall = {
41 enable = true;
42 allowPing = true;
43 allowedTCPPorts = [ 22 # ssh
44 ];
45 allowedUDPPortRanges = [ { from = 60000; to = 61000; } # mosh
46 ];
47 };
48
49 # This value determines the NixOS release with which your system is to be
50 # compatible, in order to avoid breaking some software such as database
51 # servers. You should change this only after NixOS release notes say you
52 # should.
53 system.stateVersion = "18.09"; # Did you read the comment?
54
55}