diff options
Diffstat (limited to 'odin.nix')
-rw-r--r-- | odin.nix | 12 |
1 files changed, 5 insertions, 7 deletions
@@ -32,7 +32,7 @@ | |||
32 | ]; | 32 | ]; |
33 | boot.kernelPackages = pkgs.linuxPackages_latest; | 33 | boot.kernelPackages = pkgs.linuxPackages_latest; |
34 | 34 | ||
35 | boot.extraTTYs = [ "tty7" ]; | 35 | console.extraTTYs = [ "tty7" ]; |
36 | 36 | ||
37 | boot.initrd.network = { | 37 | boot.initrd.network = { |
38 | enable = true; | 38 | enable = true; |
@@ -45,10 +45,8 @@ | |||
45 | networking.hostName = "odin"; # Define your hostname. | 45 | networking.hostName = "odin"; # Define your hostname. |
46 | 46 | ||
47 | # Select internationalisation properties. | 47 | # Select internationalisation properties. |
48 | i18n = { | 48 | i18n.defaultLocale = "en_US.UTF-8"; |
49 | consoleKeyMap = "dvp"; | 49 | console.keyMap = "dvp"; |
50 | defaultLocale = "en_US.UTF-8"; | ||
51 | }; | ||
52 | 50 | ||
53 | # Set your time zone. | 51 | # Set your time zone. |
54 | time.timeZone = "Europe/Berlin"; | 52 | time.timeZone = "Europe/Berlin"; |
@@ -531,7 +529,7 @@ | |||
531 | # servers."localhost:${toString config.services.bar.port}"= {}; | 529 | # servers."localhost:${toString config.services.bar.port}"= {}; |
532 | # }; | 530 | # }; |
533 | "prometheus" = { | 531 | "prometheus" = { |
534 | servers."${config.services.prometheus2.listenAddress}" = {}; | 532 | servers."${config.services.prometheus.listenAddress}" = {}; |
535 | }; | 533 | }; |
536 | "grafana" = { | 534 | "grafana" = { |
537 | servers."localhost:${toString config.services.grafana.port}" = {}; | 535 | servers."localhost:${toString config.services.grafana.port}" = {}; |
@@ -550,7 +548,7 @@ | |||
550 | }; | 548 | }; |
551 | }; | 549 | }; |
552 | 550 | ||
553 | services.prometheus2 = { | 551 | services.prometheus = { |
554 | enable = true; | 552 | enable = true; |
555 | extraFlags = ["--web.enable-admin-api"]; | 553 | extraFlags = ["--web.enable-admin-api"]; |
556 | webExternalUrl = "https://odin.asgard.yggdrasil/prometheus"; | 554 | webExternalUrl = "https://odin.asgard.yggdrasil/prometheus"; |