summaryrefslogtreecommitdiff
path: root/odin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'odin.nix')
-rw-r--r--odin.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/odin.nix b/odin.nix
index 21054dbc..ffff5b9a 100644
--- a/odin.nix
+++ b/odin.nix
@@ -8,6 +8,7 @@
8 imports = 8 imports =
9 [ # Include the results of the hardware scan. 9 [ # Include the results of the hardware scan.
10 ./odin/hw.nix 10 ./odin/hw.nix
11 ./users.nix
11 ]; 12 ];
12 13
13 # Use the GRUB 2 boot loader. 14 # Use the GRUB 2 boot loader.
@@ -46,10 +47,16 @@
46 ]; 47 ];
47 }; 48 };
48 49
50 users.extraUsers.root = let
51 template = import ./users/gkleen.nix;
52 in {
53 inherit (template) shell;
54 openssh.authorizedKeys.keyFiles = template.openssh.authorizedKeys.keyFiles;
55 };
56
49 # This value determines the NixOS release with which your system is to be 57 # This value determines the NixOS release with which your system is to be
50 # compatible, in order to avoid breaking some software such as database 58 # compatible, in order to avoid breaking some software such as database
51 # servers. You should change this only after NixOS release notes say you 59 # servers. You should change this only after NixOS release notes say you
52 # should. 60 # should.
53 system.stateVersion = "18.09"; # Did you read the comment? 61 system.stateVersion = "18.09"; # Did you read the comment?
54
55} 62}