summaryrefslogtreecommitdiff
path: root/modules/envfs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/envfs.nix')
-rw-r--r--modules/envfs.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/modules/envfs.nix b/modules/envfs.nix
index ff992b61..b5b453a5 100644
--- a/modules/envfs.nix
+++ b/modules/envfs.nix
@@ -26,9 +26,9 @@ in {
26 26
27 options = { 27 options = {
28 services.envfs = { 28 services.envfs = {
29 enable = lib.mkEnableOption (lib.mdDoc "Envfs filesystem") // { 29 enable = lib.mkEnableOption "Envfs filesystem" // {
30 default = true; 30 default = true;
31 description = lib.mdDoc '' 31 description = ''
32 Fuse filesystem that returns symlinks to executables based on the PATH 32 Fuse filesystem that returns symlinks to executables based on the PATH
33 of the requesting process. This is useful to execute shebangs on NixOS 33 of the requesting process. This is useful to execute shebangs on NixOS
34 that assume hard coded locations in locations like /bin or /usr/bin 34 that assume hard coded locations in locations like /bin or /usr/bin
@@ -40,7 +40,7 @@ in {
40 type = lib.types.package; 40 type = lib.types.package;
41 default = pkgs.envfs; 41 default = pkgs.envfs;
42 defaultText = lib.literalExpression "pkgs.envfs"; 42 defaultText = lib.literalExpression "pkgs.envfs";
43 description = lib.mdDoc "Which package to use for the envfs."; 43 description = "Which package to use for the envfs.";
44 }; 44 };
45 45
46 paths = lib.mkOption { 46 paths = lib.mkOption {
@@ -60,7 +60,7 @@ in {
60 ''') 60 ''')
61 ] 61 ]
62 ''; 62 '';
63 description = lib.mdDoc "Extra packages to join into collection of fallback executables in case not other executable is found"; 63 description = "Extra packages to join into collection of fallback executables in case not other executable is found";
64 }; 64 };
65 }; 65 };
66 }; 66 };