summaryrefslogtreecommitdiff
path: root/modules/borgcopy/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/borgcopy/default.nix')
-rw-r--r--modules/borgcopy/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/modules/borgcopy/default.nix b/modules/borgcopy/default.nix
index afc6c37b..475edbd9 100644
--- a/modules/borgcopy/default.nix
+++ b/modules/borgcopy/default.nix
@@ -61,33 +61,40 @@ in {
61 options = { 61 options = {
62 from = mkOption { 62 from = mkOption {
63 type = types.str; 63 type = types.str;
64 description = "Copy from this repository";
64 }; 65 };
65 to = mkOption { 66 to = mkOption {
66 type = types.str; 67 type = types.str;
68 description = "Copy to this repository";
67 }; 69 };
68 70
69 verbosity = mkOption { 71 verbosity = mkOption {
70 type = types.int; 72 type = types.int;
71 default = 3; 73 default = 3;
74 description = "Set verbosity";
72 }; 75 };
73 76
74 sshConfig = mkOption { 77 sshConfig = mkOption {
75 type = with types; nullOr str; 78 type = with types; nullOr str;
76 default = null; 79 default = null;
80 description = "SSH client configuration";
77 }; 81 };
78 82
79 keyfile = mkOption { 83 keyfile = mkOption {
80 type = with types; nullOr str; 84 type = with types; nullOr str;
81 default = null; 85 default = null;
86 description = "Keyfile to pass to borg";
82 }; 87 };
83 88
84 unknownUnencryptedRepoAccessOk = mkOption { 89 unknownUnencryptedRepoAccessOk = mkOption {
85 type = types.bool; 90 type = types.bool;
86 default = false; 91 default = false;
92 description = "Set `BORG_UNKNOWN_UNENCRYPTED_REPO_ACCESS_IS_OK`?";
87 }; 93 };
88 hostnameIsUnique = mkOption { 94 hostnameIsUnique = mkOption {
89 type = types.bool; 95 type = types.bool;
90 default = true; 96 default = true;
97 description = "Set `BORG_HOSTNAME_IS_UNIQUE`?";
91 }; 98 };
92 99
93 timerOptions = mkOption { 100 timerOptions = mkOption {
@@ -96,10 +103,12 @@ in {
96 default = { 103 default = {
97 wantedBy = ["timers.target"]; 104 wantedBy = ["timers.target"];
98 }; 105 };
106 description = "Systemd timer options";
99 }; 107 };
100 }; 108 };
101 }); 109 });
102 default = {}; 110 default = {};
111 description = "Copy borg archives from one repository to another";
103 }; 112 };
104 }; 113 };
105 114