summaryrefslogtreecommitdiff
path: root/installer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'installer.nix')
-rw-r--r--installer.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/installer.nix b/installer.nix
new file mode 100644
index 00000000..3bdca7ab
--- /dev/null
+++ b/installer.nix
@@ -0,0 +1,34 @@
1{ config, pkgs, lib, ... }:
2
3{
4 imports = [
5 <nixpkgs/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix>
6 <nixpkgs/nixos/modules/installer/cd-dvd/channel.nix>
7 ];
8
9 boot.kernelPackages = pkgs.linuxPackages_latest;
10
11 systemd.services.sshd.wantedBy = lib.mkForce [ "multi-user.target" ];
12
13 environment.systemPackages = with pkgs; [
14 mosh
15 tmux
16 zsh
17 pythonPackages.magic-wormhole
18 ];
19
20 networking = {
21 hostName = "";
22
23 firewall = {
24 enable = true;
25 allowPing = true;
26 allowedTCPPorts = [ 22 # ssh
27 ];
28 allowedUDPPortRanges = [ { from = 60000; to = 61000; } # mosh
29 ];
30 };
31 };
32
33 i18n.consoleKeyMap = "dvp";
34}